Read First: SotS/BoB/CE Problems (All Dists)

Tech support. This is tech support. My name is Ernie.
Darloth
Posts: 1885
Joined: Thu Apr 26, 2007 4:38 pm

Post by Darloth » Sat Apr 05, 2008 5:32 am

Hate to say this and not be able to help further, but I doubt your problem is (purely) vista related.

I have vista home running on a laptop, and BoB (gamer's gate edition) works just fine on it. I have an nVidea graphics card though, so it could just be that it won't work on the graphics card... but in that case, I have no idea why SotS vanilla works.

Try fiddling with DirectX and graphics drivers?

User avatar
Quester
Posts: 365
Joined: Sun Mar 04, 2007 3:37 pm

Re: Read First: Common SotS & BoB Retail Problems (All Dists

Post by Quester » Mon May 26, 2008 8:11 pm

I currantly have the original SotS, I want to be sure that when I load BoB that I can still play SotS when I'm feeling nostalgic.

User avatar
zanzibar196
Note: Not A Moderator
Posts: 8181
Joined: Sat Aug 19, 2006 7:29 am

Re: Read First: Common SotS & BoB Retail Problems (All Dists

Post by zanzibar196 » Mon May 26, 2008 9:02 pm

Quester wrote:I currantly have the original SotS, I want to be sure that when I load BoB that I can still play SotS when I'm feeling nostalgic.


Well, if you did it as a seperate install you could... and I seriously doubt you will ever get nostalgic after playing the CE for a bit... :D
Image

Image

User avatar
Quester
Posts: 365
Joined: Sun Mar 04, 2007 3:37 pm

Re: Read First: Common SotS & BoB Retail Problems (All Dists

Post by Quester » Tue May 27, 2008 5:56 am

Is there supposed to be audio for the last trailer on the bonus cd? If so did someone post it on youtube or something? I can't hear anything from that trailer but i am from the others.

User avatar
silvaril
Kerbicron Cleric
Kerbicron Cleric
Posts: 3631
Joined: Thu Aug 25, 2005 9:11 pm

Yay, a Knowledge Base article...

Post by silvaril » Thu Jul 10, 2008 10:38 pm

Heya

For the increasingly common Vista Virtualisation issues...

http://support.microsoft.com/kb/927387


Alternatively, I recommend re-installing the game to "X:\Games\Sword of the Stars", where "X:" is the hard drive / partition you want the game to live on.

This is particularly recommended if you think you might like to try out some Mods or do some modding yourself.
silvaril wrote:Love is Love, God is God and I am still Living a Lifetime

Disclaimer:
The views of any individual may not necessarily represent those of "God"(tm)

User avatar
BlueTemplar
Posts: 3131
Joined: Wed Aug 29, 2007 9:15 am

Re:

Post by BlueTemplar » Fri Jul 11, 2008 3:03 am

Chibiabos wrote:Hello,

I am having this very issue of the game not starting at all in Windows Vista (Home Edition). I installed DirectX as per instructions, but BoB will not start at all (Sword of the Stars original does start and run).

I [BLEEP]ing hate Vista, but its what came with my p.o.s. laptop. It won't let a program create files in its own directory unless you run as Administrator, and doing so I get a session log attempting to start BoW:

Root directory: "C:\Program Files\Stardock\TotalGaming\Sword of the Stars - Born of Blood"
Mounting current directory... OK
Mounting sots_local_en.gob... OK
Mounting sots.gob... OK
Warning: Could not create D3D Device!


According to DXDIAG, Direct 3D is enabled, but I cannot access acceleration settings in the Display Settings. My graphics adapter is the Intel Mobile 945 Express.


Did you try this?
viewtopic.php?f=13&t=8676&p=156596#p156596

Obsidian
Posts: 86
Joined: Wed Sep 20, 2006 1:14 pm

Re: Read First: SotS/BoB/CE Problems (All Dists)

Post by Obsidian » Sun Oct 05, 2008 9:16 pm

Almost every Fleet Command seems broken. Stand Off, and Pull Back is gibbed! The ships refuse to do anything of the sort. I have noted however during AI battles, the commands seem to work flawlessly... Missile ships pull back to a further range, etc.

viperpaktu
Posts: 497
Joined: Fri Aug 24, 2007 3:42 am

Re: Read First: SotS/BoB/CE Problems (All Dists)

Post by viperpaktu » Sun Oct 05, 2008 9:26 pm

Obsidian wrote:Almost every Fleet Command seems broken. Stand Off, and Pull Back is gibbed! The ships refuse to do anything of the sort. I have noted however during AI battles, the commands seem to work flawlessly... Missile ships pull back to a further range, etc.


It's a bit weird. I issued a stand off command to a fleet of DE's attacking a swarm asteroid, and all but 2 of the DE's did just that. The last 2 said "NO! We like smushing our noses up against the rock!" and refused to move, regardless of how many times I pressed stand off.
"I won't start this fight, but by God I'll finish it!" - John Sheridan
Image

Obsidian
Posts: 86
Joined: Wed Sep 20, 2006 1:14 pm

Re: Read First: SotS/BoB/CE Problems (All Dists)

Post by Obsidian » Mon Oct 06, 2008 1:04 am

viperpaktu wrote:It's a bit weird. I issued a stand off command to a fleet of DE's attacking a swarm asteroid, and all but 2 of the DE's did just that. The last 2 said "NO! We like smushing our noses up against the rock!" and refused to move, regardless of how many times I pressed stand off.


Nothing seems to work for me. I'm getting a bit frustrated with the game too, despite me liking it. Again, the worst part is seeing the AI perform the order so flawlessly (and obviously), but none of my ships respond at all! Having to manually order groups of ships is a real pain. Click a target, and then select Stand Off results in the ship just barreling headlong into the target, as if I never issued an order at all! What's worse is that I have to wait until the expansion is released for my game to get fixed? *sigh*

I wonder why viperpaktu, yours works while mine doesn't? I'm using version 1.53 Collectors' Edition. If anyone has any suggestions, I'd be VERY grateful.

viperpaktu
Posts: 497
Joined: Fri Aug 24, 2007 3:42 am

Re: Read First: SotS/BoB/CE Problems (All Dists)

Post by viperpaktu » Mon Oct 06, 2008 1:32 am

Obsidian wrote:I wonder why viperpaktu, yours works while mine doesn't? I'm using version 1.53 Collectors' Edition. If anyone has any suggestions, I'd be VERY grateful.



Ack. I wish I had read this just a couple minutes earlier. I have both the CE (updated) and AMoC installed. My results were based off of AMoC; and I just finished playing a game of CE with a friend about 10 minutes ago. Next time I'm playing with him, I'll have to see if it works or not.
"I won't start this fight, but by God I'll finish it!" - John Sheridan
Image

Obsidian
Posts: 86
Joined: Wed Sep 20, 2006 1:14 pm

Re: Read First: SotS/BoB/CE Problems (All Dists)

Post by Obsidian » Mon Oct 06, 2008 1:50 am

Okay so let me get this straight. An install of the CE, followed by Update 1.53, right? Sigh... I know it's correct... just trying to clutch at anything to fix what's broken.

I assume if I backup my saved games folder and do a reinstall, the save games will still be compatible? Anyways, thanks for your help so far. If you get a chance to try that out for yourself, get back to me. Now I'm curious whether or not it works for you with the CE only...

User avatar
Nspace
Kerbicron Cleric
Kerbicron Cleric
Posts: 4668
Joined: Thu Dec 29, 2005 7:26 pm

Re: Read First: SotS/BoB/CE Problems (All Dists)

Post by Nspace » Tue Oct 07, 2008 10:56 pm

Obsidian wrote:I assume if I backup my saved games folder and do a reinstall, the save games will still be compatible?

Yes, they will be compatible. If you are going between the CE and AMoC, they will still work just fine, but games saved in the CE may not have access to all the new tech in AMoC.

And as for why your fleet commands don't seem to be working, I'm not sure but you may try telling your fleet to stop it's movement orders (the "S" key), then giving your fleet a single target before you click the command. That's the only thing I can think of off the top of my head.
"Quando omni flunkus, mortati" - "When all else fails, play dead"
SotS 1 wiki: http://wiki.swordofthestars.com/sots1/Main_Page
SotS 2 wiki: http://wiki.swordofthestars.com/sots2/SotS2_Codex

Obsidian
Posts: 86
Joined: Wed Sep 20, 2006 1:14 pm

Re: Read First: SotS/BoB/CE Problems (All Dists)

Post by Obsidian » Tue Oct 07, 2008 11:24 pm

Nspace wrote:
Obsidian wrote:And as for why your fleet commands don't seem to be working, I'm not sure but you may try telling your fleet to stop it's movement orders (the "S" key), then giving your fleet a single target before you click the command. That's the only thing I can think of off the top of my head.


Thanks for the info. I'll try the Stop command next time I fire up the game then, I'll get back to you guys here when I do.

BlackLiger
Posts: 2
Joined: Fri Jan 23, 2009 10:58 pm

Re: Read First: SotS/BoB/CE Problems (All Dists)

Post by BlackLiger » Fri Jan 23, 2009 11:58 pm

Hi. My copy of the game is acting VERY strangely.

My copies of Sword of the Stars and Born of Blood are both bought via Impulse (Stardock).

My copy of Murder of Crows, however, was purchased as a direct download from "Gamers Gate" (www.gamersgate.com).

However, whenever I try to install AMOC, I get the error message "SOTS: A Murder of Crows is already up to date or the existing installation is damaged. Please re-install Born of Blood before trying to continue."

I have tried reinstalling SOTS and BOB both, from scratch, as clean, fresh installs. This has not fixed this error.

I am using Windows XP, Service pack 2, with all but the very latest updates, and my drivers for my graphics card are up to date. I have enough harddrive space to install AMOC (about 50 times over).

Any assistance would be appreciated, even if it requires me to get a refund from Gamers Gate and wait for AMOC to come out on Impulse.

User avatar
Zabaron
Zuul Survivor
Zuul Survivor
Posts: 1814
Joined: Sun Jul 30, 2006 4:46 am

Re: Read First: SotS/BoB/CE Problems (All Dists)

Post by Zabaron » Sat Jan 24, 2009 12:35 am

See my post here.

-Zabaron
"ʎq ʎlɟ ʎǝɥʇ sɐ ǝʞɐɯ ʎǝɥʇ punos ƃuıɥsooʍ ʇɐɥʇ ǝʌol ı ˙sǝuılpɐǝp ǝʌol ı"
sɯɐpɐ sɐlƃnop-

Post Reply

Return to “Technical Support”

Who is online

Users browsing this forum: Google [Bot] and 2 guests