Unable to play Multiplayer

Tech support. This is tech support. My name is Ernie.
Locked
Husaria
Posts: 1
Joined: Thu Dec 06, 2012 12:08 pm

Unable to play Multiplayer

Post by Husaria » Thu Dec 06, 2012 12:18 pm

HI everyone,

A friend and i have been having some problems playing multiplayer - starting tonight. We have played together before without problem, so the problem is recent (Started within the last 24 hours of this post, roughly)

So, When I tried to host a new game I got a message saying matchmaker support had been pulled, but people could still join manually. Not a problem, I thought. So, we traded IP addresses, but things kept timing out (no matter who hosted)

Next we tried port forwarding, and that seemed to fix the initial problem. However, now whenever we try connect we get a 'host not ready' error message.

Some googling revealed this is some kind of anti-piracy method activated when both sides have the same CD key (Granted that was only mentioned once in a forum post, so the grounds for it is admittedly shaky). The thing is, Both of us bought the game through Steam, (sots complete collection) and have played fine before. A quick look in the registry revealed neither of us actually have CD keys at all, and indeed there is no 'view CD key' option on steam as there is with other games (and as the sots wiki suggests there should be)

So, how can we fix the problem and get back to conquering the galaxy?

User avatar
castewarkp
Site Admin
Posts: 1653
Joined: Fri Aug 05, 2005 6:11 pm

Re: Unable to play Multiplayer

Post by castewarkp » Sat Dec 08, 2012 1:55 am

Some information on the matter. We're trying to find out more.

viewtopic.php?f=56&t=38765

Locked

Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest