Help!

Lookin' for a fight? Lookin' to talk about a fight? Talk about your multiplayer tactics here.
dast
Posts: 553
Joined: Mon Apr 09, 2012 1:44 pm

Re: Help!

Post by dast » Sat Dec 01, 2012 7:58 am

No need for tcp 27015 .. You only need UDP on all three ports.
If it does not work you might want to check that you set three single port forwards and no ranges.
Other think what caused me a week of headaches is the used ip.
Check wether you have a full ipv4 support.

SancheZ1993
Posts: 130
Joined: Tue Jun 28, 2011 2:33 pm

Re: Help!

Post by SancheZ1993 » Sat Dec 01, 2012 8:13 am

Incorrect. Without 27015 and tcp some annoying desyncs presents.

User avatar
Starknight
Posts: 651
Joined: Thu Sep 22, 2011 6:31 am

Re: Help!

Post by Starknight » Sat Dec 01, 2012 1:55 pm

dast wrote:No need for tcp 27015 .. You only need UDP on all three ports.
If it does not work you might want to check that you set three single port forwards and no ranges.
Other think what caused me a week of headaches is the used ip.
Check wether you have a full ipv4 support.


Castewar wrote the new blurb on the launcher, and assured me it's TCP and UDP for 27015 when I presented the wrong information (based on the wrong information in the launcher for the release of EoF) to another player in chat. I'm going to assume the dev knows what he's talking about. :)
My Morrigi fleet-speed calculator for SotS Prime
The Holy Lands - Hivers vs. the infidel Liir (and others)
Currently working on getting my board game Dragon Raiders into final condition before going to Kickstarter...

dast
Posts: 553
Joined: Mon Apr 09, 2012 1:44 pm

Re: Help!

Post by dast » Sat Dec 01, 2012 10:22 pm

i stand corrected,

initialy i had set the forwards after looking at the network traffic and googled the steam ports.
Because it worked for me i never checked for more ports/protocols.

Thanks

User avatar
Hawawaa
Posts: 1490
Joined: Fri Sep 09, 2011 11:37 pm

Re: Help!

Post by Hawawaa » Mon Feb 04, 2013 2:12 am

Just going to update this, you can either port forward or port trigger. Make sure to tell your firewall for sots.exe and marz.exe allow (in and out). If you have a antivirus say norton do the same.

User avatar
Hawawaa
Posts: 1490
Joined: Fri Sep 09, 2011 11:37 pm

Re: Help!

Post by Hawawaa » Sun Mar 10, 2013 3:58 am

I figured out how to host or what was holding me back. Kill norton during multi so you can host. ;)

User avatar
Hawawaa
Posts: 1490
Joined: Fri Sep 09, 2011 11:37 pm

Re: Help!

Post by Hawawaa » Thu Apr 04, 2013 1:44 pm

Placing this here for others to make life easier I hope-
Hawawaa wrote:Hopefully one of these tips helps ya.

Update router firmware.

If you have an antivirus like Norton turn it off. Turn it on after your multiplayer session is over. (Now you may not have to turn off your Antivirus and add in in and out rules for it. But I know Norton is being a problem child so it has to be off.)

If port forwarding isn't helping ya try port triggering (it's in advanced settings on your router and you enter in the same numbers).

Do windows search for "firewall" and jump into your firewall (windows firewall and advanced security). The inbound and outbound rules do the following: to allow both Sots2.exe and Mars.exe inbound and outbound rules. (the .exes are in main drive, steam/steamapps/common/sots2/bin/x86 and in there you should eyeball both of them)
(double click the rule and you will have to do this 4 times ie 4 rules total for in and out) in general tab under action set it to allow connection.
If you move over to advanced tab make sure Domain, Private and Public are all checked (if you see Edge Traversal below Profiles in advanced tab set to allow and note this is for inbound rules not out fyi.) (one last thing in protocols and ports for all 4 rules your making make sure any and all ports in 2 tabs below are selected)

Now before you setup your game to host, click refresh button ie the host and then go set your game up.

This is all I know. Hope it helps.
Last edited by Hawawaa on Sat Feb 22, 2014 12:50 am, edited 4 times in total.

User avatar
Hawawaa
Posts: 1490
Joined: Fri Sep 09, 2011 11:37 pm

Re: Help!

Post by Hawawaa » Tue Dec 10, 2013 12:06 pm

Bumb for new players.

User avatar
Hawawaa
Posts: 1490
Joined: Fri Sep 09, 2011 11:37 pm

Re: Help!

Post by Hawawaa » Sat Feb 22, 2014 12:36 am

bumpage

User avatar
Hawawaa
Posts: 1490
Joined: Fri Sep 09, 2011 11:37 pm

Re: Help!

Post by Hawawaa » Tue Nov 04, 2014 5:00 pm

Das BUMP! (sticky for new players please?)

Post Reply

Return to “Multiplayer Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests