CTD after launching game

Post any bumps you find on the road to galactic domination.

Moderators: Makail, Erinys, ddub

Post Reply
Skywalker
Posts: 232
Joined: Mon Apr 13, 2009 7:46 pm

CTD after launching game

Post by Skywalker » Fri Oct 02, 2015 10:26 am

Hello. As of yesterday I started getting CTDs after trying to start the game.
Starting launcher -> clicking "Play" button. -> getting long error message

Code: Select all

---------------------------
SotS Error
---------------------------
An error occurred:
System.Xml.XmlException: Root element is missing.

   at System.Xml.XmlTextReaderImpl.Throw(Exception e)

   at System.Xml.XmlTextReaderImpl.ParseDocumentContent()

   at System.Xml.XmlTextReaderImpl.Read()

   at System.Xml.XPath.XPathDocument.LoadFromReader(XmlReader reader, XmlSpace space)

   at System.Xml.XPath.XPathDocument..ctor(Stream stream)

   at Kerberos.Sots.Profile.LoadProfile(String profileName, Boolean absolutepath)

   at Kerberos.Sots.App.ProcessEngineMessage(ScriptMessageReader mr)

   at Kerberos.Sots.App.Update()

Refer to log file for more information:
C:\Users\Talassar\AppData\Local\Sword of the Stars II\log\log-20151002131322.txt


Here is theat log

Code: Select all


T (2015/10/02 13:19:14) [app] MARS2 32-bit Retail Environment 2.0.25104.1
T (2015/10/02 13:19:14) [app] Last built on Aug 22 2014 16:06:55
T (2015/10/02 13:19:14) [app] CWD:
T (2015/10/02 13:19:14) [app]   E:\Game\Steam\steamapps\common\Sword of the Stars II\bin\x86
T (2015/10/02 13:19:14) [app] Args:
T (2015/10/02 13:19:14) [app]   E:\Game\Steam\steamapps\common\Sword of the Stars II\bin\x86\mars.exe
T (2015/10/02 13:19:14) [app]   -nSword of the Stars II
T (2015/10/02 13:19:14) [app]   -g..\..\assets
T (2015/10/02 13:19:14) [app]   +deployed
T (2015/10/02 13:19:14) [app]   -w1024
T (2015/10/02 13:19:14) [app]   -h720
T (2015/10/02 13:19:14) [app]   -locale:uk
T (2015/10/02 13:19:14) [app]   +window
T (2015/10/02 13:19:14) [app]   +rfxaa
T (2015/10/02 13:19:14) [app]   +rbloom
T (2015/10/02 13:19:14) [app]   +rfblur
T (2015/10/02 13:19:14) [app]   +rrefract
T (2015/10/02 13:19:14) [app]   +rocclude
T (2015/10/02 13:19:14) [app]   +planetgen
T (2015/10/02 13:19:14) [app]   +rdecal
T (2015/10/02 13:19:14) [app]   -console
T (2015/10/02 13:19:14) [app]   -rmipbias0
T (2015/10/02 13:19:14) [test] All unit tests begin.
T (2015/10/02 13:19:14) [test] All unit tests end. Time (secs): CPU 0.001000 Wall 0.000000.
T (2015/10/02 13:19:14) [app] Application window initialized.
T (2015/10/02 13:19:15) [d3d10] Context initialized (DriverType=0).
T (2015/10/02 13:19:15) [app] Mount points will be configured for deployment.
W (2015/10/02 13:19:15) [app] MOUNT FAILED: [base_ru] E:\Game\Steam\steamapps\common\Sword of the Stars II\assets\base_ru
W (2015/10/02 13:19:15) [app] MOUNT FAILED: [base_de] E:\Game\Steam\steamapps\common\Sword of the Stars II\assets\base_de
T (2015/10/02 13:19:15) [app] Mounted path: [base] E:\Game\Steam\steamapps\common\Sword of the Stars II\assets\base
T (2015/10/02 13:19:15) [app] Mounted path: [eof] E:\Game\Steam\steamapps\common\Sword of the Stars II\assets\eof
T (2015/10/02 13:19:15) [app] Mounted path: [dlc_human] E:\Game\Steam\steamapps\common\Sword of the Stars II\assets\dlc_human
T (2015/10/02 13:19:15) [app] Mounted path: [dlc_hiver] E:\Game\Steam\steamapps\common\Sword of the Stars II\assets\dlc_hiver
T (2015/10/02 13:19:15) [app] Mounted path: [dlc_tarkas] E:\Game\Steam\steamapps\common\Sword of the Stars II\assets\dlc_tarkas
T (2015/10/02 13:19:15) [app] Mounted path: [dlc_liir_zuul] E:\Game\Steam\steamapps\common\Sword of the Stars II\assets\dlc_liir_zuul
T (2015/10/02 13:19:15) [app] Mounted path: [dlc_morrigi] E:\Game\Steam\steamapps\common\Sword of the Stars II\assets\dlc_morrigi
T (2015/10/02 13:19:15) [app] Mounted path: [dlc_zuul] E:\Game\Steam\steamapps\common\Sword of the Stars II\assets\dlc_zuul
T (2015/10/02 13:19:15) [phys] Engine Initialize start: E:\Game\Steam\steamapps\common\Sword of the Stars II\assets\base.
T (2015/10/02 13:19:15) [phys] Engine initialized.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'SupplyIcon'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'PowerIcon'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'CrewIcon'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'RightBannerCap'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'ButtonLC'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'ButtonFill'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'ButtonRC'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'AvatarFrameTRC'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'ButtonLC'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'ButtonFill'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'ButtonRC'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'Budget_ring'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'Budget_glow'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'Budget_ref'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'Hiver_Badge_11'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'liir_badge_11'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'adaptive_tracking'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'GreenLazer'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'advanced_leviathan_construction'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'col_crybaby'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'col_flock'.
W (2015/10/02 13:19:15) [gui] Ignoring redefiniton of sprite 'col_tarpit'.
W (2015/10/02 13:19:15) [gui] Template 'dialogIntelSuccess_SingleFleetDetails' is not a valid template definition.
W (2015/10/02 13:19:15) [gui] Template 'dialogIntelSuccess_SystemInfo' is not a valid template definition.
W (2015/10/02 13:19:15) [gui] Template 'dialogIntelSuccess_DefenceLayout' is not a valid template definition.
W (2015/10/02 13:19:15) [gui] Template 'dialogIntelSuccess_CurrentResearch' is not a valid template definition.
W (2015/10/02 13:19:15) [gui] Template 'dialogIntelSuccess_AllFleetLocations' is not a valid template definition.
W (2015/10/02 13:19:15) [gui] Template 'dialogIntelSuccess_LastDesignsBuilt' is not a valid template definition.
W (2015/10/02 13:19:15) [gui] Template 'dialogIntelSuccess_NewestColonyPosition' is not a valid template definition.
W (2015/10/02 13:19:15) [gui] Template 'dialogIntelSuccess_CurrentAdmirals' is not a valid template definition.
W (2015/10/02 13:19:15) [gui] Template 'dialogIntelSuccess_HighestTradeSystem' is not a valid template definition.
W (2015/10/02 13:19:15) [gui] Template 'dialogIntelSuccess_PsionicPower' is not a valid template definition.
W (2015/10/02 13:19:15) [gui] Template 'dialogIntelSuccess_NavalStationDetails' is not a valid template definition.
W (2015/10/02 13:19:15) [gui] Template 'dialogIntelSuccess_PlayerTreaties' is not a valid template definition.
W (2015/10/02 13:19:15) [gui] Template 'dialogIntelSuccess_LastMissions' is not a valid template definition.
W (2015/10/02 13:19:15) [gui] Template 'dialogIntelSuccess_LastAlliancePms' is not a valid template definition.
T (2015/10/02 13:19:15) [state] Preparing SplashState for transition from nothing.
W (2015/10/02 13:19:15) [game] System.Xml.XmlException: Root element is missing.

   at System.Xml.XmlTextReaderImpl.Throw(Exception e)

   at System.Xml.XmlTextReaderImpl.ParseDocumentContent()

   at System.Xml.XmlTextReaderImpl.Read()

   at System.Xml.XPath.XPathDocument.LoadFromReader(XmlReader reader, XmlSpace space)

   at System.Xml.XPath.XPathDocument..ctor(Stream stream)

   at Kerberos.Sots.Profile.LoadProfile(String profileName, Boolean absolutepath)

   at Kerberos.Sots.App.ProcessEngineMessage(ScriptMessageReader mr)

   at Kerberos.Sots.App.Update()
W (2015/10/02 13:19:19) [log] An error occurred. Refer to the log and associated minidump files for more information:

C:\Users\Talassar\AppData\Local\Sword of the Stars II\log\log-20151002131914.txt
C:\Users\Talassar\AppData\Local\Sword of the Stars II\log\log-20151002131914.txt.dmp


Before that there wasn't a single problem running this version of a game.

WIn 10 x64
Laptop Asus g73jW
GPU GeForce GTX460M
CPU QuadCore i7 q740 - 1.73 ghz (3 ghz in turbo mode which i always run)


Also verified game's cash in steam settings.

Skywalker
Posts: 232
Joined: Mon Apr 13, 2009 7:46 pm

Re: CTD after launching game

Post by Skywalker » Fri Oct 02, 2015 10:41 am

Upd. This is bloody awesome X_X
2 days of this !rawr , tried all workarounds i found. nothing helps.
Posted question at forum and it suddenly starts working on its own >.<

User avatar
Mecron
Kerberos
Posts: 38503
Joined: Fri Aug 05, 2005 7:26 pm

Re: CTD after launching game

Post by Mecron » Fri Oct 02, 2015 7:41 pm

do you have auto updates on for windows?

Skywalker
Posts: 232
Joined: Mon Apr 13, 2009 7:46 pm

Re: CTD after launching game

Post by Skywalker » Sat Oct 03, 2015 8:32 pm

Yeah I do. Last update happened square in mid of this blackout. Game started CTDing, next day I got autoupdate, installed it and several reboots (and about half a day+) game started working again.

Post Reply

Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 2 guests