Consistent turn Crash Error

Post any bumps you find on the road to galactic domination.

Moderators: Makail, Erinys, ddub

Post Reply
Posts: 15
Joined: Sun Apr 17, 2011 7:10 pm

Consistent turn Crash Error

Post by AotrsCommander » Thu May 25, 2017 6:01 pm

This is a pretty vain hope, but for the sake of it, I'll make it anyway. I appreciate that the game is no longer officially supported, so I'm asking the community as much as anyone.

I have reached a point in the game where it constently crashes between turns (after resolving combats). I went back about eight turns and tried again and got one turn further before getting the same error. It is quite far into the game (turn 691/962), though I've played games that have gone welol into the 700s before.

This is the Steam version. I have done the obvious check of validating the files.

I don't suppose anyone knows what might be causing this (or if it can be fixed, say by futzing with the save file)? I'd rather not have to write off a 50-hour game just as it was getting interesting (only just got Impactors ready to go!)

The error is this:

An error ocurred:
System.InvalidOperationException: Sequence contains no elements as System.Linq.Enumerable.First[TSource](IEnumerable`1 source)
at Kerberos.Sots.Strategy.InhabitedPlanet.Colony.SimulatedPlagues(GameSession sim, ColonyInfo& ci, Planetinfo& pi, List`1& plagues)
at Kerberos.Sots.Strategy,InhabitedPlanet.Colony.MaintainColony(GameSession sim, ColonyInfo& colony, PlanetInfo& planet, List`1& civPopulation,Boolean& achchievedSuperWorld, Boolean isSupplyRun)
at Kerberos.Sots.Strategy.GameSession.Phase6_EndOfTurnBookKeeping()
at Kerberos.Sots.Strategy.GameSession.NextTurn()
at Kerberos.Sots.Strategy.GameSession.CombatComplete()
at Kerberos.Sots.Strategy.GameState.StarMapState.OnEnter()
at Kerberos.Sots.Strategy.GameState.Enter()
at Kerberos.Sots.Strategy.GameStateMachine.Update()
at Kerberos.Sots.App.Update()

It then gives me a log file (C:\Users:\NAME\AppData\Local\Sword of the starsII\log\

Clicking okay on that screen gives me a "no disk in the drive error." (My version is Steam and thus had no disk.)

It then gives me a Mars error and more log files.

Reading the error message as I typed it out this time, might it have something to do with me using the assimilation plague? (It appeared to work on one planet previously, but I've never tried it in a game before this one.) Maybe glassing the planet might work...? (I'll go try that...!)

I fully expect that this can't be fixed, but I figured I might as well ask anyway (and this i also the only only place remotely officially SotS2 related to even go winge a bit about the bad luck of I have to write this off...!)


Huh. Okay. So I glassed the planet, and it did indeed let me progress to the next turn. So. Okay, then. Well, I suppose it was worth the effort of typing all of that out (and thsu reading it) and making this post, since I guess I know the work around (stop trying to use Assimilation plague), so I can carry on, and, I suppose, in case anyone else run into this issue, they might find the solution...

User avatar
Posts: 1730
Joined: Sun Nov 11, 2012 5:38 am

Re: Consistent turn Crash Error

Post by Rossinna-Sama » Fri May 26, 2017 5:12 am

Which race did you use the assimilation plague on?
Sword of the Stars 2 : Project Hiver Modder
Creator of the Work-In-Progress Seimei Visual Novel series.
My dream game: Combination of Sword of the Stars 2, Angels Fall First, Conquest: Frontier Wars and Warzone 2100.

Posts: 15
Joined: Sun Apr 17, 2011 7:10 pm

Re: Consistent turn Crash Error

Post by AotrsCommander » Fri May 26, 2017 9:37 am

I was playing Liir, and using it on Tarka. (After one successful use on the same empire once that game, which worked.)

It was definitely that, by-the-by, SotS2 ran pefectly all night afterwards.

Post Reply

Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest