Launch error.

Problems with the PC Alpha Demo? Let us know!
(the demo being Alpha doesn't count as a technical support issue)
Post Reply
Fahry
Posts: 12
Joined: Mon Mar 11, 2013 6:06 pm

Launch error.

Post by Fahry » Wed Aug 14, 2013 11:27 am

Getting "The procedure entry point SHGetKnownFolderPath could not be located in the dynamic link library SHELL32.dll. " error on launch.

Google says this API is available only on Vista or newer versions so I assume Windows XP is not supported at the moment. Is that so ?

User avatar
Makail
Kerberos
Posts: 48
Joined: Wed Aug 17, 2011 8:29 pm

Re: Launch error.

Post by Makail » Wed Aug 14, 2013 6:43 pm

It is so! We will look into making it backward compatible with Windows XP.
Makail

wrax
Posts: 6
Joined: Fri Jun 28, 2013 9:46 pm

Re: Launch error.

Post by wrax » Wed Sep 04, 2013 11:16 pm

well, that should be noted somewhere :) (or it is...?)
I lost some time to figure that out.
Aplha screens looks like old XP comps should be quite ok with this game

User avatar
shadow wolf
Posts: 808
Joined: Tue Aug 23, 2011 2:45 pm

Re: Launch error.

Post by shadow wolf » Wed Sep 11, 2013 7:04 pm

Makail wrote:It is so! We will look into making it backward compatible with Windows XP.

The problem is not solved yet? It is necessary to wait for the next alpha?
http://www.panzercentral.com/forum/view ... 35&t=49885

User avatar
ddub
Kerberos
Posts: 2409
Joined: Fri Oct 14, 2011 6:24 pm

Re: Launch error.

Post by ddub » Wed Sep 11, 2013 7:13 pm

Can you post your dxdiag?
It should work with XP.
The game requires the computer to be able to run OpenGL 2.

Thanks,

User avatar
shadow wolf
Posts: 808
Joined: Tue Aug 23, 2011 2:45 pm

Re: Launch error.

Post by shadow wolf » Wed Sep 11, 2013 7:37 pm

ddub wrote:Can you post your dxdiag?
It should work with XP.
The game requires the computer to be able to run OpenGL 2.

attached
rocked the alpha here:
http://www.gamershell.com/download_102535.shtml
You do not have the required permissions to view the files attached to this post.

User avatar
shadow wolf
Posts: 808
Joined: Tue Aug 23, 2011 2:45 pm

Re: Launch error.

Post by shadow wolf » Mon Sep 30, 2013 1:56 pm

ddub wrote:It should work with XP.
The game requires the computer to be able to run OpenGL 2.

The problem in C++ ? I have searched for information and found this:
Используйте функцию SHGetSpecialFolderPath с константами CSIDL. В программах для Windows Vista и более новых версий используйте функцию SHGetKnownFolderPath с константами KNOWNFOLDERID. Подробности по ссылкам:

* SHGetSpecialFolderPath
* CSIDL
* SHGetKnownFolderPath
* KNOWNFOLDERID

http://officemacro.wordpress.com/2013/06/20/save-files/

In Shell32.lib for XP no SHGetKnownFolderPath (with constants KNOWNFOLDERID). There used SHGetSpecialFolderPath (with constants CSIDL).
You can fix this?

User avatar
ddub
Kerberos
Posts: 2409
Joined: Fri Oct 14, 2011 6:24 pm

Re: Launch error.

Post by ddub » Tue Oct 01, 2013 5:09 pm

We've set up some XP systems in our office, we will be looking into this issue.

Thanks,

User avatar
shadow wolf
Posts: 808
Joined: Tue Aug 23, 2011 2:45 pm

Re: Launch error.

Post by shadow wolf » Tue Oct 01, 2013 7:15 pm

I think part of the old players are using Windows XP. Thank you.

User avatar
ddub
Kerberos
Posts: 2409
Joined: Fri Oct 14, 2011 6:24 pm

Re: Launch error.

Post by ddub » Wed Feb 12, 2014 3:16 am

Newest update now supports XP.

Thanks,

User avatar
shadow wolf
Posts: 808
Joined: Tue Aug 23, 2011 2:45 pm

Re: Launch error.

Post by shadow wolf » Sun Feb 23, 2014 9:56 pm

ddub wrote:Newest update now supports XP.


I have a question. Just description page confused me. May need to be fixed on DirectX 9 ?
OS: Windows XP, Vista, 7, 8
...
DirectX: Version 10

http://store.steampowered.com/app/267730/

Windows XP ≠ DirectX 10

Post Reply

Return to “Alpha Demo Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest