[1.3.0.56] Welsh Memory Leak blocks screenshots?

Giant monsters take a lot of work to keep running. Report any issues here!

Moderator: Erinys

Post Reply
Defenestar
Posts: 983
Joined: Thu Apr 30, 2015 7:51 am

[1.3.0.56] Welsh Memory Leak blocks screenshots?

Post by Defenestar » Sun Feb 05, 2017 4:55 pm

So there's a thing that happens sometimes when the game's been running for a bit, with rectangles instead of the images of of particular units or buildings, they're usually black, but the one for the supertank has additional light brown ones around the outside of it.

I'd hit the screenshot button a few times when these came up, and when exiting the game immediately after those battles (assuming it did not crash before that happened, but these are not times of great stability) the background would be missing on the title screen. Like the game name is visible, and the frame, but the bit where you'd see mad scientists at their desk and the WORLD viewer behind them is just all white.

And when I looked at my screenshots to see which one to put up here so you could see it, windows claims that those images are corrupt. I'll upload one of them, and the diag from after the crash that followed my most recent attempt to take a shot. And the autosave too now that I think of it.

I'd been intending to post about Ignition Beam not setting anything on fire, but I'm pretty sure that is another manifestation of the same effect where explosions from things like Havoc Overload fail to smash anything, and KDF guns go quiet for a few moments, and that seems like memory leak stuff to me.
You do not have the required permissions to view the files attached to this post.

who
Posts: 57
Joined: Fri Jul 24, 2015 11:55 pm

Re: [1.3.0.56] Welsh Memory Leak blocks screenshots?

Post by who » Tue Feb 07, 2017 2:00 pm

If it was already at the point where it's showing textures that failed to load properly then taking a screenshot would defiantly break it since a screenshot is essentially rendering a new texture of the current screen and saving it.

Defenestar
Posts: 983
Joined: Thu Apr 30, 2015 7:51 am

Re: [1.3.0.56] Welsh Memory Leak blocks screenshots?

Post by Defenestar » Tue Feb 07, 2017 3:51 pm

Another mystery solved. Thank you.

Post Reply

Return to “Technical Support-A-GoGo”

Who is online

Users browsing this forum: No registered users and 1 guest